Skip to main content
All CollectionsDomain Owner UIInstallation
cPanel, WHM, Plesk & DirectAdmin Plugin/Module
cPanel, WHM, Plesk & DirectAdmin Plugin/Module

Installation of the Monarx Domain Owner UI (control panel plugin)

Will avatar
Written by Will
Updated this week

This article shows how to install the Monarx Domain Owner UI. The Domain Owner UI is designed to integrate out-of-the box with popular control panels, but can also be easily integrated with any web experience once a domain owner is authenticated. In the latter case, no separate installation is required.

The Monarx control panel plugins require the Agent to be installed first, and assume that Monarx repo has been set up for use as part of Agent installation.

Monarx uses RPM packages managed via yum for CentOS / CloudLinux.

Install the control panel plugin packages with yum

To install the cPanel plugin:

sudo yum install monarx-cpanel-plugin

To install the WHM plugin:

sudo yum install monarx-whm-plugin 

To install the Plesk plugin:

sudo yum install monarx-plesk-plugin

To install the DirectAdmin plugin:

sudo yum install monarx-da-plugin 

Updating the control panel plugin packages with yum

To update the cPanel plugin:

sudo yum update monarx-cpanel-plugin

To update the WHM plugin:

sudo yum update monarx-whm-plugin 

To update the Plesk plugin:

sudo yum update monarx-plesk-plugin

To update the DirectAdmin plugin:

sudo yum update monarx-da-plugin 

Removing the control panel plugin packages with yum

To remove the cPanel plugin:

sudo yum remove monarx-cpanel-plugin

To remove the WHM plugin:

sudo yum remove monarx-whm-plugin 

To remove the Plesk plugin:

sudo yum remove monarx-plesk-plugin

To remove the DirectAdmin plugin:

sudo yum remove monarx-da-plugin 

Note that you may need to enable the Monarx plugin for use by your users via each control panel's administration tools, depending on how you have the control panel configured.

Also note that the Monarx control panel plugins for the Domain Owner UI are currently only supported on CentOS versions 6 -> 9 / CloudLinux versions 6 -> 9 with the use of the Paper Lantern and Jupiter themes. Support for other OS's, versions, and themes will be coming soon. Plesk plugin supports the prior and additionally Debian 9, 10, 11 and Ubuntu 20 & 22.

Did this answer your question?